High Availability: HSRP, VRRP and GLBP --Go Figure

In essence all three protocols provide failover capability in an event where one router / L3 switch goes down. HSRP and VRRP are quite similar in terms of functionality however the former is Cisco proprietary and the later is industry standard.
One of the major limitations with HSRP and VRRP is they are not true load balancing protocols, hence poor resource utilization of standby routers/switches is a common issue unless multiple groups and gateways are configured.
Spotting this Gap, Cisco introduced GLBP in 2005, apart from failover capability GLBP provides upstream load sharing by utilizing the redundant uplinks simultaneously; below I have outlined some points highlighting features of the three protocols.

Cisco hot standby router protocol (HSRP)
·         Hot Standby Router Protocol (HSRP) is a Cisco proprietary redundancy protocol for establishing a fault-tolerant default gateway, and has been described in detail in RFC 2281.
·         HSRP allows the gateways to be organized into standby groups.
  • Created in 1994.
  • Uses a default HELLO timer for 3 seconds with a hold timer of 10 seconds.
  • HSRP active and standby routers send hello messages to the multicast address 224.0.0.2 using UDP port 1985
  • Primarily used for fail over purposes, partial load balancing is possible by creating multiple groups and assigning multiple default gateways, administrative over head
  • Configuration example with basic load balancing configured (2 groups)

DLS1#show running-config
interface Vlan11
ip address 172.16.11.5 255.255.255.0
standby 1 priority 150
standby 1 ip 172.16.11.10
standby 2 priority 50
standby 2 ip 172.16.11.20

DLS2#show running-config
interface Vlan10
ip address 172.16.11.6 255.255.255.0
no ip redirects
standby 1 priority 50
standby 1 ip 172.16.11.10
standby 2 priority 150
standby 2 ip 172.16.11.20

Virtual router redundancy protocol (VRRP)
·         VRRP is a non-proprietary redundancy protocol described in RFC 3768 designed to increase the availability of the default gateway servicing hosts on the same subnet.
  • Create by the IETF in 1999.
  • Vendor independent.
  • Has faster timers than HSRP by default, Advertisements of 1 second, Hold timer of 3 Seconds.
  • Advertisements are sent on multicast 224.0.0.18 protocol number 112
  • In VRRP only the master sends advertisements.


VRRP configuration example
DLS1(config)#interface vlan11
DLS1(config-if)#ip address 172.16.11.5 255.255.255.0 
DLS1(config-if)#vrrp 11 ip 172.16.11.1
DLS1(config-if)#vrrp 11 priority 150
DLS2(config)#interface vlan11
DLS2(config-if)#ip address 172.16.11.6 255.255.255.0
DLS2(config-if)#vrrp 11 ip 172.16.11.1
DLS2(config-if)#vrrp 11 priority 100

Gateway load balancing protocol (GLBP)

·         Gateway Load Balancing Protocol (GLBP) is a Cisco proprietary protocol that attempts to overcome the limitations of existing redundant router protocols by adding basic load balancing functionality.
  • Cisco proprietary, created in 2005.
  • Identical features of HSRP, but allows an active-active connection that adds load balancing.
  • GLBP members communicate with each other using hello messages sent every 3 seconds to the multicast address 224.0.0.102, UDP port 3222.
  • GLBP supports Weighted load-balancing algorithm, Host-dependent load-balancing algorithm AND Round-robin load-balancing algorithm operational modes


GLBP configuration example
DLS1(config)#interface vlan11
DLS1(config-if)#ip address
172.16.11.5 255.255.255.0
DLS1(config-if)#glbp 11 ip
172.16.11.1
DLS1(config-if)#glbp 11 priority 150
DLS1(config-if)#glbp 11 timers msec 250 msec 750

DLS2(config)#interface vlan11
DLS2(config-if)#ip address
172.16.11.6 255.255.255.0
DLS2(config-if)#glbp 11 ip
172.16.11.1
DLS2(config-if)#glbp 11 priority 100
DLS2(config-if)#glbp 11 timers msec 250 msec 750



Thanks
Huzeifa Bhai

No comments:

Post a Comment